Задать вопрос
15 февраля, 15:31

Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара.

+4
Ответы (1)
  1. 15 февраля, 16:12
    0
    Const

    Pi=3.1416;

    var

    n:integer;

    r:real;

    begin

    Write ('Укажите вариант расчета и радиус: ') ;

    Read (n, r) ;

    case n of

    1:Writeln ('Длина окружности равна ',2*Pi*r) ;

    2:Writeln ('Пдощадь круга равна ', Pi*r*r) ;

    3:Writeln ('Объем шара равен ',4/3*Pi*r*r*r)

    else Writeln ('Вариант должет быть равен 1,2 или 3')

    end

    end.

    Пример

    Укажите вариант расчета и радиус: 3 11.7

    Объем шара равен 6708.8365344
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая по введенному номеру и величине радиуса вычисляла: 1 - длину окружности, 2 - площадь круга, 3 - объем шара. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы