Задать вопрос
30 ноября, 11:03

Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры)

+1
Ответы (1)
  1. 30 ноября, 14:31
    0
    program ml;

    uses crt;

    var x, i:integer;

    w, l:real;

    begin

    clrscr;

    readln (x) ;

    L:=x;

    for i:=1 to x do begin

    w:=w+1;

    l:=x/w;

    if frac (l) = 0 then writeln (l:2:0) ;

    end;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу выводящую на экран все делители на число х. (число х вводится с клавиатуры) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы