Задать вопрос
13 марта, 19:33

Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если программа предложила большее число то пользователь нажимает а если угадала то =

Тема циклы

+4
Ответы (1)
  1. 13 марта, 22:03
    0
    var min, max, n:integer;

    c:string;

    Begin

    min:=1;

    max:=1000;

    repeat

    n: = (max+min) div 2;

    writeln (n) ;

    read (c) ;

    case c of

    ">": min:=n+1;

    "<": max:=n-1;

    end

    until (c="=") ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке pascal которая будет угадывать число от 1 до 1000 задуманное пользователем за наименьщее число шагов если ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы