Задать вопрос
12 апреля, 15:45

Напишите программу, которая находит квадрат произведения цифр

введенного числа

+4
Ответы (1)
  1. 12 апреля, 16:36
    0
    Var a, p:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a:=abs (a) ;

    p:=1;

    while a0 do

    begin

    p:=p * (a mod 10) ;

    a:=a div 10;

    end;

    p:=p*p;

    writeln ('p = ', p) ;

    end.

    Пример:

    a = 273

    p = 1764
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая находит квадрат произведения цифр введенного числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы