Задать вопрос
30 октября, 08:00

Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Опре-делить: а) за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; б) через сколько месяцев размер вклада превысит 1200 руб.

+5
Ответы (1)
  1. 30 октября, 11:37
    0
    Var s, ds:real; k1, k2:integer;

    begin

    //a

    s:=1000; ds:=0; k1:=0;

    while ds<=30 do

    begin

    ds:=s*0.02;

    s:=s+ds;

    k1:=k1+1;

    end;

    writeln ('k1 = ', k1) ;

    //б

    s:=1000; ds:=0; k2:=0;

    while s<=1200 do

    begin

    s:=1.02*s;

    k2:=k2+1;

    end;

    writeln ('k2 = ', k2) ;

    end.

    Результат:

    k1 = 22

    k2 = 10
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке Паскаль: Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы