Задать вопрос
17 апреля, 08:28

1) Напишите программу в Паскале

Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ввести с клавиатуры)

+2
Ответы (1)
  1. 17 апреля, 11:02
    0
    var

    mas: array[-1000 ... 1000] of integer;

    i, k, n: integer;

    begin

    {ввод количества элементов массива}

    readln (n) ;

    {ввод числа к}

    readln (k) ;

    {ввод массива и его вывод на экран}

    randomize;

    for i : = 1 to n do

    begin

    mas[i] : = 50 - random (100) - 1;

    write (mas[i]:4) ;

    if (i mod 10 = 0) then writeln;

    end;

    {замена элементов массива}

    writeln;

    for i:=1 to n do begin

    if (mas[i] mod k=0) then mas[i]:=0

    else

    mas[i]:=1;

    write (mas[i]:4) ;

    if (i mod 10 = 0) then writeln;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Напишите программу в Паскале Заполнить массив случайными целыми числами. Заменить элементы массива, кратные K нулями, остальные 1 (К ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы