Задать вопрос
13 июля, 17:06

Помогите написать программу на языке Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Кто правильно напишет поставлю лучшее решение!

+1
Ответы (2)
  1. 13 июля, 18:22
    0
    Var a: array [1 ... 100] of integer;

    chis, i: integer;

    begin

    readln (chis) ;

    for i:=1 to chis do readln (a[i]) ;

    write ('Числа кратные 4:') ;

    for i:=1 to chis do if (a[i] mod 4 = 0) then write (a[i], ' ') ;

    end.
  2. 13 июля, 21:06
    0
    Var n, a, i, k:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    k:=0;

    writeln ('Вводите числа:') ;

    for i:=1 to n do

    begin

    readln (a) ;

    if a mod 4 = 0 then k:=k+1;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    n = 5

    Вводите числа:

    15

    24

    73

    48

    94

    k = 2
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на языке Паскаль. Напишите программу, которая в последовательности натуральных чисел определяет количество ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы