Задать вопрос
2 февраля, 01:00

Дан массив целых чисел, состоящий из 25 элементов. заполните его с клавиатуры. Найти: сумму элементов имеющих нечётные индексы; подсчитать количество элементов массива, значения которых больше заданного числа А и кратны 5

+3
Ответы (1)
  1. 2 февраля, 02:20
    0
    Const n=25;

    var b:array[1 ... n] of integer;

    s, k, a, i:integer;

    begin

    writeln ('vvedite massiv') ;

    for i:=1 to n do

    readln (b[i]) ;

    writeln ('a=') ;

    readln (a) ;

    k:=0;

    s:=0;

    for i:=1 to n do

    if i mod 2=1 then s:=s+b[i];

    if (b[i]>a) and (b[i] mod 5=0) then inc (k) ;

    writeln ('s=', s,' k=', k) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив целых чисел, состоящий из 25 элементов. заполните его с клавиатуры. Найти: сумму элементов имеющих нечётные индексы; подсчитать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)