Задать вопрос
13 сентября, 05:46

Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и вставляющую после запятой пробел.

Дана строка, содержащая пробел. Написать программу, меняющую местами части строки до и после пробела и добавляющую в конец строки вопросительный знак.

+2
Ответы (1)
  1. 13 сентября, 07:15
    0
    1.

    var s:string; p:integer;

    begin

    readln (s) ;

    p:=pos ('_', s) ;

    delete (s, p, 1) ;

    insert (', ', s, p) ;

    writeln (s) ;

    end.

    Пример:

    program_begin

    program, begin

    2.

    var s:string; l, p:integer;

    begin

    readln (s) ;

    l:=length (s) ;

    p:=pos (' ', s) ;

    s:=copy (s, p+1, l-p+1) + ' '+copy (s, 1, p-1) + '?';

    writeln (s) ;

    end.

    Пример:

    program begin

    begin program?
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана строка, содержащая два слова, разделенные знаком нижнее подчеркивание. Написать программу заменяющую нижнее подчеркивание на запятую и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы