Задать вопрос
5 октября, 01:50

Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о соотношении суммы крайних цифр и суммы средних цифр этого числа (меньше, больше или равны).

+3
Ответы (1)
  1. 5 октября, 04:39
    0
    Var a, a1, a2, a3, a4, s1, s2:integer;

    begin

    readln (a) ;

    a1:=a div 1000;

    a2:=a div 100 mod 10;

    a3:=a mod 100 div 10;

    a4:=a mod 10;

    s1:=a1+a4; s2:=a2+a3;

    if s1>s2 then writeln (s1,' > ', s2)

    else if s1
    else writeln (s1,' = ', s2) ;

    end.

    Пример:

    4382

    6 < 11
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу: с клавиатуры вводится четырехзначное целое число. Вывести на экран сообщение о соотношении суммы крайних цифр и суммы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы