Задать вопрос
28 мая, 15:17

Паскаль. Найти наименьшее среди положительных из 10 чисел, введенных с клавиатуры (пределы изменения не заданы)

+5
Ответы (1)
  1. 28 мая, 16:18
    0
    Uses Crt;

    const n=10;

    var

    A: array[1 ... n] of integer;

    i, f, f1: integer;

    begin

    clrscr;

    f:=-1;

    f1:=-1;

    for i:=1 to n do

    begin

    writeln ('введите', i,' элемент массива ') ;

    readln (A[i]) ;

    if A[i]>0 then

    begin

    f1:=A[i];

    if f<0 then

    f:=A[i];

    if f>f1 then

    f:=A[i];

    end;

    end;

    writeln ('наименьшее положительное', f) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. Найти наименьшее среди положительных из 10 чисел, введенных с клавиатуры (пределы изменения не заданы) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)
С клавиатуры вводятся N чисел. Составьте программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введенных чисел. Значение N и сами числа вводится с клавиатуры.
Ответы (2)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)