Задать вопрос
6 октября, 08:01

С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ

+1
Ответы (1)
  1. 6 октября, 08:54
    0
    var

    slovo, simval:string;

    i, k:integer;

    begin

    k:=0;

    write ('Введите имя и фамилию ') ;

    readln (slovo) ;

    write ('Введите символ ') ;

    readln (simval) ;

    for i:=1 to length (slovo) do

    begin

    if slovo[i]=simval then k:=k+1;

    if slovo[i]=simval then writeln (i,' ') ;

    end;

    if k>=1 then

    writeln ('Да, встречается ', k,' раз, на позиции ', i) else writeln ('Нет') ;

    end.

    Я немножко перевыполнил) От показывает есть симаол или нет, если есть то сколько раз он входит и на какой позиции ...
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры одной строкой вводят имя и фамилию. Составьте программу, которая определяет, есть ли во введенной строке заданный символ ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы