Задать вопрос
23 сентября, 16:36

Написать программу на языке си + + вычислить сумму ряда до 20 члена s = ((-1) * (k!+1) * x^k) / 3^k

+3
Ответы (1)
  1. 23 сентября, 20:22
    0
    Исходя из вашего запроса:

    без отрицания k

    #include

    using namespace std;

    int main ()

    {

    int a, k, s, x;

    for (k=0; k<20; k++)

    {

    s + = ((-1) * (k+1) * x^k) / 3^k;

    }

    cout << s << endl;

    system ("pause") ; / / или _getch () ;

    return 0;

    }

    с отрицанием k

    #include

    using namespace std;

    int main ()

    {

    int a, k, s, x;

    for (k=0; k<20; k++)

    {

    s + = ((-1) * (k+1) * x^k) / 3^k;

    }

    cout << s << endl;

    system ("pause") ; / / èëè _getch () ;

    return 0;

    }

    и формулируйте вопрос корректнее.

    в обоих решениях k=0 изначально
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке си + + вычислить сумму ряда до 20 члена s = ((-1) * (k!+1) * x^k) / 3^k ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы