Задать вопрос
4 марта, 12:29

Написать программу на языке паскаль (разветвляющийся алгоритм) :

1) F=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x умножить на x)

2) S=1/2ab (одна вторая а б)

3) С=a2-b2 (а в квадрате минус б в квадрате)

+2
Ответы (2)
  1. 4 марта, 12:47
    0
    1) Не разветвление)

    program xizt;

    uses crt;

    var x, f:real;

    begin

    writeln ('введите х') ;

    readln (x) ;

    f:=sqr (x) - 3;

    writeln (f) ;

    end.

    2) program xizt;

    uses crt;

    var a, b, s:real;

    begin

    writeln ('введите a, b через пробел') ;

    readln (a, b) ;

    s:=1/2*a*b

    writeln (s) ;

    end.

    3) program xizt;

    uses crt;

    var a, b, c:real;

    begin

    writeln ('введите a, b через') ;

    readln (a, b) ;

    c:=sqr (a) - sqr (b) ;

    writeln (c) ;

    end.
  2. 4 марта, 16:07
    0
    Var x, f, s, c, a, b:real;

    begin

    write ('X = ') ;

    readln (x) ;

    write ('A = ') ;

    readln (a) ;

    write ('B = ') ;

    readln (b) ;

    f:=x*x-3;

    s:=a*b/2;

    c:=a*a-b*b;

    writeln ('F=', f:3:2,' S=', s:3:2,' C=', c:3:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке паскаль (разветвляющийся алгоритм) : 1) F=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы