Задать вопрос
17 июня, 04:02

Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца

+4
Ответы (1)
  1. 17 июня, 07:49
    0
    Var

    m: array [1 ... 31] of integer; / / заполненный массив

    sr: real; / / средняя сумма

    sum: integer; / / сумма всех элементов

    i: integer;

    a: integer; //значений выше

    b: integer; //значений ниже

    c: integer; //равных среднему

    begin

    for i : = 1 to 31 do

    sum : = sum + m[i];

    sr : = sum / 31;

    for i : = 1 to 31 do

    if m[i] > sr then

    a : = a + 1

    else if m[i] < sr then

    b : = b + 1

    else c : = c + 1;

    writeln (a) ;

    writeln (b) ;

    writeln (c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу подсчитывающую сколько дней в январе было с температурой выше, ниже и равной средней температуре месяца ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы