Задать вопрос
2 марта, 02:01

Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. (Паскаль)

+1
Ответы (1)
  1. 2 марта, 03:34
    0
    Var x, n, m, f, s: integer;

    begin

    write ('Введите N: ') ; readln (n) ;

    write ('Введите M: ') ; readln (m) ;

    write ('Введите F: ') ; readln (f) ;

    for x : = 1 to n do

    if (x mod m = f) then s : = s + sqr (x) ;

    writeln ('Сумма: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления суммы квадратов первых N членов натурального ряда, каждое из которых при делении на M дает в остатке F. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы