Задать вопрос
24 октября, 20:34

определить зарплату работнику по больничному листу, проболевшему К дней при следующих условиях,

если стаж работы

до 6 лет - 60%,

от 6-8 - 80%,

более 8 - 100 %,

если несовершеннолетний - 100 %,

зарплата работника Z рублей в день.

+3
Ответы (1)
  1. 24 октября, 20:51
    0
    Паскаль

    uses crt;

    var m:string; k, l, z:real;

    begin

    clrscr;

    writeln ('Укажите количество дней.') ; read (k) ;

    writeln ('Укажите зарплату работника.') ; read (z) ;

    writeln ('Работник совершеннолетний? да/нет.') ;

    read (m) ;

    if (m='да') then write ('Зарплата составит ', z,'руб.') ;

    if (m='нет') then

    begin

    writeln ('Укажите стаж работы') ; read (l) ;

    if l<6 then write ('Зарплата составит ', z*0.6,'руб.') ;

    if l>8 then write ('Зарплата составит ', z,'руб.')

    else write ('Зарплата составит ', z*0.8,'руб.') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «определить зарплату работнику по больничному листу, проболевшему К дней при следующих условиях, если стаж работы до 6 лет - 60%, от 6-8 - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Составить алгоритм (схему) начисления зарплаты согласно следующему правилу: если стаж работы сотрудника менее 5 лет, то зарплата 13 тыс. руб., при стаже работы от 5 до 15 лет - 18 тыс. руб.
Ответы (1)
Pascal В списке сотрудников фирмы (мужчин) заданы стаж их работы и семейное положение. Определить холостого работника с наименьшим стажем работы.
Ответы (1)
Напишите программу в Pascal компьютер спрашивает возраст и стаж, на работу принимает если кандидат старше 25 лет и имеет стаж не менее 10 лет
Ответы (1)
Выключить монитор Ход работы: Отсоединить монитор от компьютера Ход работы: Отсоединить мышь и клавиатуру Ход работы: Отсоединить все остальные имеющиеся внешние устройства кабеля Ход работы: Подключить к компьютеру монитор Ход работы: Подключить к
Ответы (1)
Учитель проверяет работы письменного экзамена. Изначально на его столе нет ни одной работы. Иногда приносят стопку работ с подряд идущими номерами, при этом номера работ увеличиваются от низа стопки к ее верху.
Ответы (1)