Задать вопрос
13 сентября, 01:15

Каждая бактерия делится на 2 в течение одной минуты. В начальный момент имеется одна бактерия. Составить программу, которая рассчитывает кол-во бактерий на заданное Вам целое значение момента времени. pascal abc

+5
Ответы (1)
  1. 13 сентября, 02:24
    0
    Var t, a, i: integer;

    begin

    write ('Введите количество минут: ') ;

    read (t) ;

    a:=1;

    for i:=1 to t do

    begin

    a:=a*2;

    writeln ('Бактерий через ', i, ' минут: ', a) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Каждая бактерия делится на 2 в течение одной минуты. В начальный момент имеется одна бактерия. Составить программу, которая рассчитывает ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Новые вопросы по информатике