Задать вопрос
31 июля, 04:05

Написать программу в Free Pascal:

Дано целое число неизвестной размерности. Найти сумму цифр его составляющих.

+1
Ответы (1)
  1. 31 июля, 06:25
    0
    Var n, sum:integer;

    begin

    sum:=0;

    write ('N = ') ;

    readln (n) ;

    while n 0 do

    begin

    sum:=sum+n mod 10;

    n:=n div 10;

    end;

    writeln ('Summa: ', sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Free Pascal: Дано целое число неизвестной размерности. Найти сумму цифр его составляющих. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы