Задать вопрос
13 мая, 17:20

Напишите программу, которая принимает с клавиатуры число и превращает его в положительное, если оно отрицательное, либо в ноль во всех остальных случаях.

+2
Ответы (2)
  1. 13 мая, 17:42
    0
    Program zadacha;

    var x:integer;

    Begin

    readln (x) ;

    if (x<0) then a:=abs (x)

    else a:=0;

    writeln (x) ;

    end.
  2. 13 мая, 19:52
    0
    var a:integer;

    begin

    readln (a) ;

    if (a<0) then a:=a * (-1) else a:=0;

    writeln (a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая принимает с клавиатуры число и превращает его в положительное, если оно отрицательное, либо в ноль во всех ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы