Задать вопрос
26 января, 13:45

Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в Турбо Паскале

+4
Ответы (2)
  1. 26 января, 16:20
    0
    Program picaso; uses crt;

    var a, b, c, s:integer;

    begin clrscr;

    writeln ('A:') ; read (a) ;

    writeln ('B:') ; read (b) ;

    writeln ('C:') ; read (c) ;

    if (a > 0) then a:=a else a:=0;

    if (b > 0) then b:=b else b:=0;

    if (c > 0) then c:=c else c:=0;

    s:=a+b+c;

    writeln (s) ;

    readln;

    end.
  2. 26 января, 16:44
    0
    Var a, b, c, ap, bp, cp:real;

    begin

    read (a, b, c) ;

    if a>0 then ap:=a else ap:=0;

    if b>0 then bp:=b else bp:=0;

    if c>0 then cp:=c else cp:=0;

    write (ap+bp+cp) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в Турбо Паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы