Задать вопрос
7 июля, 18:34

Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из формул: S=п*r; S=a*b

+5
Ответы (1)
  1. 7 июля, 20:24
    0
    var

    s, r, a, b:real;

    k:byte;

    begin

    repeat

    write ('1 - S kruga; 2 - S pryamougolnika: ') ; readln (k) ;

    until (k=1) or (k=2) ;

    if k=1 then begin

    write ('Radius: ') ; readln (r) ;

    s:=pi*r;

    writeln ('S = ', s:0:5) ;

    end else begin

    write ('A = ') ; readln (a) ;

    write ('B = ') ; readln (b) ;

    s:=a*b;

    writeln ('S = ', s:0:4) ;

    end;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить алгоритм и написать программу вычисления площади геометрической фигуры с использованием условного оператора if по одной из ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы