Задать вопрос
26 декабря, 00:16

1. составить программу входе которой определяется входит ли цифры 4 или 7 в данной 2 х значное число.

2. Составить программу входи работы которой определяется является ли данное число кратное и оканчивающиеся на 3

+4
Ответы (1)
  1. 26 декабря, 03:56
    0
    Язык не указан, Default-Language это C. На нём и напишу.

    1.

    #include

    int main ()

    Для порядку скажу что на Perl это можно реализовать проще.

    #! perl

    %h { 4 = > 0, 7 = > 0};

    ;

    if (exists $h{$_%10} || exists $h{$_/10}) {

    print "YES/n";

    else {

    print "NO/n";

    }

    Но мы ушли от темы. Итак, 2. Тут всё ещё проще:

    #include

    int main () {

    int n;

    scanf ("%d", &n) ;

    if (! (n % 3))

    printf ("Multiple of 3/n") ;

    else

    printf ("Not multiple of 3/n") ;

    if (n % 10 = = 3)

    printf ("Ends by 3/n") ;

    else

    printf ("Not ends by 3/n") ;

    return 0;

    }

    Тут более простой реализации на другом известном мне языке нету, так что приводить дополнительно ничего не буду.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. составить программу входе которой определяется входит ли цифры 4 или 7 в данной 2 х значное число. 2. Составить программу входи работы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы