Задать вопрос
4 июня, 18:46

1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.

3) Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.

4) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.

+5
Ответы (1)
  1. 4 июня, 19:25
    0
    1)

    #include

    using namespace std;

    void draw_square (int n)

    {

    for (int y = 0; y < n; y++)

    {

    for (int x = 0; x < n; x++)

    cout << "*";

    cout << endl;

    }

    }

    int main ()

    {

    int n;

    cin >> n;

    draw_square (n) ;

    return 0;

    }

    2)

    #include

    using namespace std;

    void drawNumbers (int a)

    {

    while (a > 0)

    {

    cout << a%10 << endl;

    a / = 10;

    }

    }

    int main ()

    {

    int a;

    cin >> a;

    drawNumbers (a) ;

    return 0;

    }

    3)

    #include

    using namespace std;

    int main ()

    {

    //можно гораздо быстрей, но мне лень

    int a;

    cin >> a;

    for (int i = 1; i < = a; i++) if (a%i==0) cout << i << " ";

    return 0;

    }

    4)

    #include

    using namespace std;

    void procedure (int a)

    {

    int b = a;

    int c = 1;

    while (b > 0) {c * = 10; b/=10; }

    while (c > 1)

    {

    cout << (a%c) / (c/10) << endl;

    c / = 10;

    }

    }

    int main ()

    {

    int a;

    cin >> a;

    procedure (a) ;

    return 0;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы