Задать вопрос
3 февраля, 19:15

На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет. Лена съедает одну конфету из левой вазы, затем-одну конфету из средней вазы, затем из правой, средней вазы, затем из правой, средней, левой, средней, правой, средней и т. д.

Если Лена хочет взять конфету из какой-то вазы, а конфет там нет, она расстраивается и идёт спать. Определите, сколько конфет съест Лена

Программа получает на вход три целых неотрицательных числа A, B, C-количество конфет в левой, средней, правой ВАЗе.

+3
Ответы (1)
  1. 3 февраля, 21:19
    0
    Var a, b, c, n:integer; f:boolean;

    begin

    readln (a, b, c) ;

    f:=true; n:=0;

    while f do

    begin

    if f and (a>0)

    then begin a:=a-1; n:=n+1; end else f:=false;

    if f and (b>0)

    then begin b:=b-1; n:=n+1; end else f:=false;

    if f and (c>0)

    then begin c:=c-1; n:=n+1; end else f:=false;

    if f and (b>0)

    then begin b:=b-1; n:=n+1; end else f:=false;

    end;

    writeln (n) ;

    end.

    Пример:

    3 3 3

    7
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На столе стоят три вазы с конфетами. В левой вазе лежат A конфет, в средней вообще лежат B конфет, в правой вазе лежат C конфет. Лена ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы