Задать вопрос
15 августа, 05:33

Составить программу для вычисления функции.

y={x^2, если х<2

√х, если х ≥ 2

0, если х=2

+1
Ответы (1)
  1. 15 августа, 07:03
    0
    Задание не совсем верно построено. Скорее всего вторая проверка должна быть строго больше двух, однако вот решение:

    program ff;

    var

    y, x:real;

    begin

    writeln ('Введите x') ;

    readln (x) ;

    if x<2 then y:=sqr (x) ;

    if x>=2 then y:=sqrt (x) ;

    if x=2 then y:=0;

    writeln ('y=', y) ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для вычисления функции. y={x^2, если х ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы