Задать вопрос
3 января, 23:24

составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 (каждое число с новой строки), и если среди них есть неотрицательное число, то выводит это число или выводит сумму всех отрицательных введенных чисел в остальных случаях.

+2
Ответы (1)
  1. 4 января, 03:11
    0
    Program n1;

    Uses CRT;

    Var a, b, c: integer;

    begin

    ClrScr;

    Writeln ('Vvedite chisla') ;

    Readln (a, b, c) ;

    If (a<0) and (b<0) and (c<0) then writeln ('Summa = ', a+b+c)

    else

    if (a>0) then writeln ('polozhitelnoe chislo ', a) else

    if (b>0) then writeln ('polozhitelnoe chislo ', b) else

    if (c>0) then writeln ('polozhitelnoe chislo ', c) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы