Задать вопрос
1 декабря, 03:14

1. Проверьте, является ли произведение четырёх случайных чисел, чётным числом. Составьте программу.

2. Ввести двузначное число, если сумма цифр чётная, то увеличить число на 2, в противном случае уменьшить на два.

+5
Ответы (1)
  1. 1 декабря, 06:37
    0
    Вот 1 задача:

    Program abc321;

    var a, b, c, d, e: integer;

    begin

    write ('Введите a:') ;

    readln (a) ;

    write ('Введите b:') ;

    readln (b) ;

    write ('Введите c:') ;

    readln (c) ;

    write ('Введите d:') ;

    readln (d) ;

    e : = a * b * c * d;

    if (e mod 2 = 0) then writeln ('Произведение является четным числом.') else writeln ('Произведение является нечетным числом.')

    end.

    Вот 2 задача:

    Program abc123;

    var a, b, c: integer;

    begin

    write ('Vvedite dvuznachnoe chislo: ') ;

    readln (a) ;

    b : = a div 10;

    c : = a mod 10;

    if ((b + c) mod 2 = 0) then a : = a + 2 else a : = a - 2; writeln ('a : = ', a) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Проверьте, является ли произведение четырёх случайных чисел, чётным числом. Составьте программу. 2. Ввести двузначное число, если сумма ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы