Задать вопрос
2 марта, 22:46

Составить программу в с++

Дано натуральное число:

1) найти кол-во четных цифр этого числа

2) верно ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)

+1
Ответы (1)
  1. 2 марта, 23:46
    0
    1)

    #include

    #include

    using namespace std;

    int main () {

    int a, k = 0;

    cin >> a;

    for (int b = abs (a) ; b > 0; b/=10)

    if (b%10%2 = = 0) k++;

    cout << k << endl;

    }

    2)

    #include

    #include

    using namespace std;

    int main () {

    int n, a, b;

    bool flagA = false, flagB = false;

    cin >> n >> a >> b;

    for (int d = abs (n) ; d > 0; d/=10) {

    if (d%10 = = a) flagA = true;

    else if (d%10 = = b) flagB = true;

    }

    cout << ((flagA && flagB) ? "true" : "false") << endl;

    }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в с++ Дано натуральное число: 1) найти кол-во четных цифр этого числа 2) верно ли, что в Данном числе встречается A и B ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы