Задать вопрос
17 июля, 08:45

Паскаль. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и собственного номера (нумерация элементов массива начинается с единицы). Заполните массив из n элементов, используя этот принцип и выведите значения элементов массива в обратном порядке.

Формат входных данных

Целые положительное число n (2

Целые числа a, b (-50 < a, b < 50)

Формат выходных данных

Строка, содержащая элементы искомого массива в обратном порядке, записанные через пробел

+3
Ответы (1)
  1. 17 июля, 11:34
    0
    Var n, a, b, i, j: integer;

    ar: array[1 ... 10000]of integer;

    begin

    read (n, a, b) ;

    ar[1] : = a;

    ar[2] : = b;

    for i : = 3 to n do

    begin

    for j : = 1 to i - 1 do

    begin

    ar[i] : = ar[i] + ar[j];

    end;

    ar[i] : = ar[i] + i;

    end;

    for i : = n downto 1 do write (ar[i],' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. Известно, что первые два элемента массива равны a и b. А каждый следующий элемент равен сумме значений всех предыдущих элементов и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы