Задать вопрос
9 января, 12:11

Составить программу определения количества положительных и отрицательных элементов массива целых чисел.

+2
Ответы (2)
  1. 9 января, 13:17
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of integer;

    i, ko, kp: integer;

    begin

    randomize;

    ko:=0;

    kp:=0;

    writeln ('исходный массив:') ;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    if a[i]>0 then kp:=kp+1;

    if a[i]<0 then ko:=ko+1;

    end;

    writeln;

    writeln ('кол-во пол: ', kp) ;

    writeln ('кол-во отр: ', ko) ;

    end.
  2. 9 января, 14:50
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of integer;

    i, ko, kp: integer;

    begin

    randomize;

    ko:=0;

    kp:=0;

    writeln ('исходный массив:') ;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    if a[i]>0 then

    if a[i]<0 then ko:=ko+1;

    w

    w

    e
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу определения количества положительных и отрицательных элементов массива целых чисел. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы