Задать вопрос
2 сентября, 13:23

По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000. Формат выходных данных: Необходимо вывести значение выражения

+3
Ответы (1)
  1. 2 сентября, 16:49
    0
    Program Zadacha1;

    Var n: LongInt;

    i: Integer;

    r, a: Real;

    Begin

    Write ('n = ') ;

    ReadLn (n) ;

    If n > 100000 Then

    WriteLn ('Ошибка!')

    Else

    Begin

    r : = 0;

    For i : = 0 To n Do

    Begin

    r : = r + a;

    a : = (1 - (i and 1) shl 1) * (1 / Abs (i * 2 + 1)) ;

    End;

    WriteLn ('Результат: ', r) ;

    End;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «По данному числу n вычислите сумму 2 (1-1/3+1/5-1/7 + ... + (-1) n / (2n+1)). Формат входных данных: Вводится одно число n, не ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы