Задать вопрос
13 февраля, 08:38

Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)

+1
Ответы (1)
  1. 13 февраля, 09:46
    0
    Var x, y, z:integer;

    begin

    write ('введите X: ') ;

    readln (x) ;

    write ('введите Y: ') ;

    readln (y) ;

    write ('введите Z: ') ;

    readln (z) ;

    if (x>0) and (y>0) and (z>0) then

    begin x:=x+2; y:=y+2; z:=z+2; end

    else begin x:=abs (x) ; y:=abs (y) ; z:=abs (z) ; end;

    writeln ('x = ', x) ;

    writeln ('y = ', y) ;

    writeln ('z = ', z) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы