Задать вопрос
11 декабря, 19:55

Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления:

a. суммы всех чисел последовательности;

b. среднего арифметического всех чисел последовательности:

c. суммы только отрицательных и суммы только положительных чисел последовательности.

+1
Ответы (1)
  1. 11 декабря, 21:12
    0
    Ввод нуля означает завершение ввода (он нигде не учитывается)

    program test;

    var sum, x, counter, sumOfNegative, sumOfPositive: integer; average: real;

    begin

    sum:=0;

    average:=0;

    counter:=0;

    sumOfPositive:=0;

    sumOfNegative:=0;

    read (x) ;

    while x 0 do

    begin

    sum:=sum+x;

    average:=average+x;

    counter:=counter+1;

    if x > 0 then

    sumOfPositive:=sumOfPositive+x

    else

    sumOfNegative:=sumOfNegative+x;

    read (x) ;

    end;

    average:=average/counter;

    writeln ('Sum = ', sum) ;

    writeln ('Arithmetic average = ', average) ;

    writeln ('The sum of positive numbers = ', sumOfPositive) ;

    writeln ('The sum of negative numbers = ', sumOfNegative) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы