Задать вопрос
7 июня, 20:24

Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10. в PascalABC

+3
Ответы (2)
  1. 7 июня, 20:31
    0
    Program asd;

    var chet, nechet, i:integer;

    begin

    for i:=1 to 10 do begin

    If (i div 2) = 0 then chet:=chet*i;

    If (i div 2) = 1 then nechet:=nechet+i

    end;

    Writeln (chet, nechet) ;

    end.
  2. 7 июня, 20:52
    0
    uses Crt;

    var s, i:integer;

    begin

    ClrScr;

    i:=0;

    s:=0;

    While i<10 do

    Begin

    i:=i+2;

    s:=s+i;

    end;

    writeln ('Summa chetnih ot 1 do 10 = ', s) ;

    i:=1;

    s:=1;

    While i<9 do

    Begin

    i:=i+2;

    s:=s*i;

    end;

    writeln ('Proizv nechetnih ot 1 do 10 = ', s) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая находит произведение четных чисел и сумму нечетных чисел в диапазоне от 1 до 10. в PascalABC ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Составьте программу которая находит сумму четных чисел и произведение нечетных чисел в диапазоне от 1 до 10
Ответы (1)
Составьте программу которая находит сумму четных чисел в и произведение нечетных чисел в диапазоне от 1 до 10
Ответы (1)