Задать вопрос
22 марта, 21:26

В старояпонском календаре был принят двенадцатилетний цикл. Годы внутри цикла носили названия животных: крысы, коровы, тигра, зайца, дракона, змеи, лошади, овцы, обезьяны, петуха, собаки и свиньи. Написать программу, которая позволяет ввести номер года и печататет его название по старояпонскому календарю. Справка: 1996 г. - год крысы - начало очередного цикла (остаток от деления равен 4).

+1
Ответы (1)
  1. 22 марта, 23:21
    0
    var

    n:integer;

    begin

    readln (n) ;

    case n mod 12 of

    4:writeln ('год крысы') ;

    5:writeln ('год коровы') ;

    6:writeln ('год тигра') ;

    7:writeln ('год зайца') ;

    8:writeln ('год дракона') ;

    9:writeln ('год змеи') ;

    10:writeln ('год лошади') ;

    11:writeln ('год овцы') ;

    0:writeln ('год обезьяны') ;

    1:writeln ('год петуха') ;

    2:writeln ('год собаки') ;

    3:writeln ('год свиньи') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В старояпонском календаре был принят двенадцатилетний цикл. Годы внутри цикла носили названия животных: крысы, коровы, тигра, зайца, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы