Задать вопрос
19 апреля, 15:41

Напишите программу, которая вводит трёхзначное число и десятичную цифру. Определить, входит ли эта цифра в десятичную запись введённого числа.

+5
Ответы (1)
  1. 19 апреля, 17:23
    0
    Var n, m:integer;

    begin

    write ('Число = ') ; readln (n) ;

    write ('Цифра = ') ; readln (m) ;

    if (n div 100 = m) or (n div 10 mod 10 = m) or (n mod 10 = m)

    then writeln ('Цифра есть')

    else writeln ('Цифры нет') ;

    end.

    Пример:

    Число = 519

    Цифра = 5

    Цифра есть
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая вводит трёхзначное число и десятичную цифру. Определить, входит ли эта цифра в десятичную запись введённого ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы