Задать вопрос
3 декабря, 09:26

Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case.

+3
Ответы (1)
  1. 3 декабря, 11:29
    0
    Эта программа действительна при условии, что утро начинается в 6, день в 12, вечер в 18, а ночь в 24 и продолжается до 6. Написала через if, так как не знакома с case, буду рада, если кто-нибудь мне расскажет)

    var a: integer;

    begin

    read (a) ;

    if (a > 5) and (a < = 11) then

    write ('Утро ') ;

    if (a > 11) and (a < = 17) then

    write ('День ') ;

    if (a > 17) and (a < = 23) then

    write ('Вечер') ;

    if (a = 24) or (a < 6) then

    write ('Ночь') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу которая по введенному числу из промежутка от 0 до 24 определяет время суток. через if и case. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы