Задать вопрос
22 мая, 00:51

Помогите написать программу! PascalABC. Введите массив из 5 элементов с клавиатуры и найдите количество элементов, старшая цифра которых равна 8.

+3
Ответы (1)
  1. 22 мая, 01:08
    0
    Var a: array [1 ... 5] of integer; i, amount: integer;

    begin

    read (a[1], a[2], a[3], a[4], a[5]) ;

    amount : = 0;

    for i : = 1 to 5 do

    begin

    while a[i] > = 10 do

    begin

    a[i] : = a[i] div 10;

    end;

    if a[i] = 8

    then

    amount : = amount + 1;

    end;

    writeln (amount) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу! PascalABC. Введите массив из 5 элементов с клавиатуры и найдите количество элементов, старшая цифра которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы