Задать вопрос
27 августа, 17:19

Составить программу, которая запрашивает время суток и выводит на экран соответствующие приветствие:

"доброе утро"

"доброго дня"

"доброго вечера"

"спокойной ночи"

+3
Ответы (2)
  1. 27 августа, 17:40
    0
    "доброе утро" в 7:00

    "доброго дня" в 14:00

    "доброго вечера" в 17:00

    "спокойной ночи" в 21:00
  2. 27 августа, 19:05
    0
    var hour: integer;

    minute: string;

    begin

    writeln ('Введите время суток') ;

    read (hour, minute) ;

    if (hour>=6) and (hour<12) then writeln ('Доброе утро') ;

    if (hour>=12) and (hour<18) then writeln ('Доброго дня') ;

    if (hour>=18) and (hour<00) then writeln ('Доброго вечера') ;

    if (hour>=00) and (hour<6) then writeln ('Спокойной ночи') ;

    end.

    Тут единственный недостаток: после ввода часов нужно нажать enter и минуты вводить на новой строке
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, которая запрашивает время суток и выводит на экран соответствующие приветствие: "доброе утро" "доброго дня" "доброго ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы