Задать вопрос
27 сентября, 01:27

Написать программу нахождения Ymax, если задана функция:

Y = Х2 - 100 Х + 10, где Х изменяется от Хнач. до Хкон. с шагом С. Программа должна так же выводить и значение Х, при котором Y принимает максимальное значение.

Значения Хнач., Хкон. и С должны задаваться пользователем при выполнении программы. Для организации цикла воспользуйтесь оператором While.

+2
Ответы (1)
  1. 27 сентября, 02:01
    0
    Var

    x0, xn, c:real;

    x, y, xmax, ymax:real;

    begin

    writeln ('Xнач, Xкон:') ;

    readln (x0, xn) ;

    write ('С = ') ; readln (c) ;

    x:=x0;

    xmax:=x; ymax:=x*x-100*x+10;

    while x
    begin

    x:=x+c;

    y:=x*x-100*x+10;

    if y>ymax then begin xmax:=x; ymax:=y; end;

    end;

    writeln ('xmax = ', xmax,' ymax = ', ymax) ;

    end.

    Пример:

    Xнач, Xкон:

    -10 20

    С = 1

    xmax = - 10 ymax = 1110
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу нахождения Ymax, если задана функция: Y = Х2 - 100 Х + 10, где Х изменяется от Хнач. до Хкон. с шагом С. Программа ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы