Задать вопрос
1 ноября, 10:02

1) Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему

2) Составить программу решения примера

1+2+4+6+8 ...

+3
Ответы (1)
  1. 1 ноября, 13:37
    0
    Program pr1;

    var x, y, nod:integer;

    begin

    readln (x, y) ;

    repeat

    if x > y then x:=x mod y

    else y:=y mod x

    until x*y=0;

    nod:=x+y;

    writeln ('НОД=', nod) ;

    end.

    program pr2;

    var i, n, sum:integer;

    begin

    readln (n) ;

    sum:=1;

    for i:=1 to n do

    if i mod 2 = 0 then inc (sum, i) ;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Составить программу нахождения наибольшего общего делителя НОД. Составить блок-схему 2) Составить программу решения примера 1+2+4+6+8 ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы