Задать вопрос
3 мая, 20:23

Составьте программу вычисления произведения тех значений элементов двумерного массива, которые меньше 15. Задача Паскаль

+4
Ответы (1)
  1. 3 мая, 23:04
    0
    Условие элемент массива меньше 15 и не равен нулю потому, что иначе произведение почти всегда будет равно нулю. Если оно не нужно - удали фрагмент 'and (a[i, j]0) '

    Program n1;

    Uses CRT;

    Const n=10;

    Var a: array[1 ... n, 1 ... n] of integer;

    i, j: integer; p: longint;

    begin

    p:=1;

    For i:=1 to n do

    begin

    For j:=1 to n do

    begin

    a[i, j]:=random (50) ;

    if (a[i, j]<15) and (a[i, j]0) then p:=p*a[i, j];

    write (a[i, j]:3) ;

    end;

    writeln;

    end;

    writeln ('Proizvedenie = ', p) ;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу вычисления произведения тех значений элементов двумерного массива, которые меньше 15. Задача Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы