Задать вопрос
14 апреля, 13:40

Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале)

Входные данные

Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).

Выходные данные

Программа должна вывести слово YES, если точки находятся в одной координатной четверти, в противном случае вывести слово NO.

Примеры

Входные данные

3

3

5

1

Выходные данные

YES

Паскаль

+2
Ответы (1)
  1. 14 апреля, 13:52
    0
    Замечание: предполагается, то точки не лежат на осях координат.

    var x1, y1, x2, y2:real;

    begin

    readln (x1, y1) ;

    readln (x2, y2) ;

    if (x1*x2>0) and (y1*y2>0) then writeln ('YES')

    else writeln ('NO') ;

    end.

    Пример:

    3 3

    5 1

    YES
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы