Задать вопрос
26 октября, 16:14

Составить программу для подсчета идеального веса человека. Данные для ввода: A-рост, V-возраст, P-признак (1 - мужчина, 0 - женщина)

Формулы для расчета:

Мужчины: S = (3A-450+V) * 0.25+45

Женщины: S = (3A-450+V) * 0.225+40.5

+3
Ответы (1)
  1. 26 октября, 16:47
    0
    Program n1;

    var a, v, p, s: real;

    begin

    write ('введите рост: ') ;

    readln (a) ;

    write ('введите возраст: ') ;

    readln (v) ;

    write ('введите признак (1 - мужчина, 0 - женщина) : ') ;

    readln (p) ;

    if p=1 then s: = (3*a-450+v) * 0.25+45;

    if p=0 then s: = (3*a-450+v) * 0.225+40.5;

    writeln ('идеальный вес: ', s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для подсчета идеального веса человека. Данные для ввода: A-рост, V-возраст, P-признак (1 - мужчина, 0 - женщина) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
1. Напишите программу вычисления веса идеального мужчины по формуле: Ид. Вес-Рост в см - 100 Значение роста вводится с клавиатуры. Результат вывести в следующем виде: Для мужчины ростом 165 см идеальный вес равен 65 кг. 2.
Ответы (1)
Помогите составить программу) Введите исходные данные: Возраст Коли: 12 Возраст Миши: 17 Средний возраст: 14.5 лет Возраст Колт отличается от среднего возраста на: - 2.5 лет Возраст Миши отличается от среднего возраста на: 2.5 лет
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Собери из суждений правильное умозаключение. №1 все устройства ввода служат для ввода информации. №2 клавиатура служит для ввода информации. №3 клавиатура устройство ввода
Ответы (1)
Составьте алгоритм для определения подходящего возраста кандидатуры для вступления в брак, используя следующее соображение: возраст девушки равен половине возраста мужчины+7, возраст мужчины определяется соответственно как удвоенный возраст
Ответы (1)