Задать вопрос
13 сентября, 22:40

Задание: написать программу, вычисляющую произведение элементов одномерного массива Z (N).

Рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение P:=P*Z[k] перед циклическим процессом нужно задать как 1, т. е. P:=1;

Ввод и вывод массива выполните через текстовый файл.

+5
Ответы (1)
  1. 13 сентября, 23:01
    0
    Var Z:array[1 ... 100] as integer; P:integer; i, n:integer; begin Reset (input,'input. txt') ; Rewrite (output,'output. tx) ; readln (n) ; For i:=1 to n do Readln (Z[i]) ; P:=1; For i:=1 to n do P:=p*z[i]; Writeln (p) ; Close (input) ; Close (output) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задание: написать программу, вычисляющую произведение элементов одномерного массива Z (N). Рекомендация: посмотрите алгоритм нахождения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы