Задать вопрос
8 апреля, 09:17

Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3, а к нечётное умножает на 4

+1
Ответы (1)
  1. 8 апреля, 12:31
    0
    Program Program1;

    var

    i:integer;

    a:array [1 ... 10] of integer;

    begin

    randomize;

    writeln;

    writeln ('Массив до преобразования:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (8) ;

    write (a[i],', ') ;

    end;

    for i:=1 to 10 do

    if a[i] mod 2 = 0 then

    a[i]:=a[i]+3

    else

    a[i]:=a[i]*4;

    writeln;

    writeln ('Массив после преобразования:') ;

    for i:=1 to 10 do

    write (a[i],', ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0; 7], и преобразует ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы