Задать вопрос
29 декабря, 06:29

Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. Через сколько минут температура воды станет ниже Nо С?

+1
Ответы (1)
  1. 29 декабря, 09:08
    0
    Var A, gradus, minut, N: real;

    Begin

    Writeln ('Введите A градусов') ;

    readln (A) ;

    Writeln ('До какой температуры остужать:') ;

    readln (N) ;

    gradus:=100-A; minut:=1;

    While (gradus>N) do

    Begin

    A:=A * (1-0.15) ;

    gradus:=gradus-A;

    minut:=minut+1;

    end;

    Writeln ('Кипяток остынет до ', N,' градусов через ', minut, ' минут') ;

    readln () ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу в паскаль с помощью while. Стакан кипятка (100 °С) остыл за первую минуту на А градусов, а каждую последующую минуту ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы