Задать вопрос
29 апреля, 18:31

Решение задачи и описание этапов решения. Задано натуральное число n. Найти количество натуральных чисел, не превышающих n и не делящихся ни на одно из чисел 2, 3, 5.

+4
Ответы (1)
  1. 29 апреля, 19:28
    0
    Var i, n, kol:uint64; / / Заказываем 3 переменные uint64

    begin

    read (n) ; / / Читаем n

    for i:=1 to n do begin / / Запускаем цикл перебора всех чисел

    if ((i mod 2) = 0) and ((i mod 3) = 0) and ((i mod 5) = 0) then inc (kol) ; / / Проверяем Удовлетворяет ли число

    end;

    writeln (kol) ; / / Пишем это количество

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решение задачи и описание этапов решения. Задано натуральное число n. Найти количество натуральных чисел, не превышающих n и не делящихся ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Задано натуральное число n найти количество натуральных чисел не превышающих n и не делящихся ни на одно из чисел 2,3,5. Нужно написать программу через цикл for
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программы на Паскале, используя цикл "Пока". 1) Составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N. 2) Дано целое число Х и натуральное N. Составьте алгоритм вычисления Х^N.
Ответы (1)
1. Найти количество натуральных чисел, не превышающих 100 и кратных 5. 2. Создать массив А из 10 элементов, принадлежащих промежутку (0; 25). Вывести полученный массив на экран. Подсчитать количество элементов, больших А [1]. Все с помощью Паскаля
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)