Задать вопрос
19 ноября, 19:52

Помогите с Пасклем!

На вход программе подаются три целых числа a, b, c - длины сторон треугольника. Вывести значение площади данного треугольника. Гарантируется, что с введёнными длинами сторон треугольник существует. Можно использовать любой способ нахождения площади треугольника.

+4
Ответы (1)
  1. 19 ноября, 22:22
    0
    Var a, b, c:integer; p, s:real;

    begin

    readln (a, b, c) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('s = ', s:5:2) ;

    end.

    Пример:

    3 4 5

    s = 6.00
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите с Пасклем! На вход программе подаются три целых числа a, b, c - длины сторон треугольника. Вывести значение площади данного ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы